Backtest e ajuste diário do mercado futuro



  • Bom dia, estou realizando a otimização de um robo que utiliza o indicador RSI para apoio a tomada de decisão nas operações.

    Ontem me deparei com uma situação onde o robo em produção não realizou uma operação no mini do dolar pois o RSI não estava de acordo, hoje quando fui realizar um backtest o RSI no "candle" autorizou a operação. A única explicação que imagino é o ajuste diária alterando o histórico de preço, por consequencia impactando nos indicadores.

    Gostaria de opinião de vocês, isto é possível? Qual o impacto do ajuste diário no histórico de preços e nos indicadores? Como "confiar" no backtest sendo que o histórico é ajustado?

    Estou utilizando o WDOFUT (Serie continua) no backtest.

    Obrigado,
    Júlio



  • Julio, sugiro primeiro mudar seu nome na configuração do seu PERFIL para assim ficar melhor (aproveita e bota uma foto la!!)

    Olha, você ta falando de 2 coisas diferentes: a primeira é o ajuste diário (espécie de preço de fechamento de acordo com o ativo) e o segundo é o ajuste por vencimento do contrato.
    Com sinceridade, não acho que ambos afetem seu robô.

    Sugiro verificar o LOG dele para ver possíveis erros. Ok?!

    QQ cola o log aqui.


    Abs!


    @Trader3705 said:

    Bom dia, estou realizando a otimização de um robo que utiliza o indicador RSI para apoio a tomada de decisão nas operações.
    Ontem me deparei com uma situação onde o robo em produção não realizou uma operação no mini do dolar pois o RSI não estava de acordo, hoje quando fui realizar um backtest o RSI no "candle" autorizou a operação. A única explicação que imagino é o ajuste diária alterando o histórico de preço, por consequencia impactando nos indicadores.
    Gostaria de opinião de vocês, isto é possível? Qual o impacto do ajuste diário no histórico de preços e nos indicadores? Como "confiar" no backtest sendo que o histórico é ajustado?
    Estou utilizando o WDOFUT (Serie continua) no backtest.
    Obrigado,
    Júlio


  • Obrigado pelo retorno Rodrigo, vou continuar avaliando, pegar alguns logs e retorno aqui.

    Att,
    Júlio



  • @Rodrigo-Cohen

    Bom dia Rodrigo, depois de bom tempo, volto aqui para pedir ajuda novamente.
    O problema reportado vem acontecendo com frequência, algumas operações que ocorrem no backtest não ocorreram em produção, utilizando mesmo robo e mesmo set.

    Exemplo quentinho... ontem as 15:40, WDOF17... o candle avaliado era o de inicio 15:35... Stochastic 10, 4, 4.

    *** Backtest ***
    2016.12.09 08:05:02.024 Core 1 2016.12.08 15:40:00 Validando indicadores: rsi[1]=50.20058381527284 stocValue[1]=51.13636363636363

    *** Produção ***
    2016.12.08 18:40:04.102 Hilo_MA (WDOF17,M5) Validando indicadores: rsi[1]=50.45915742371211 stocValue[1]=45.23809523809524

    Alguma dica do que pode estar ocorrendo?

    Obrigado,
    Júlio



  • Júlio, eu passo pela mesma situação. O que você fez para contornar isso ?



  • Bom dia, não resolvi ainda... mas o que já percebi é que na conta teste e na conta produção em tempo real os indicadores também possuem dados divergentes.

    Sempre fiz o backtest na conta teste, agora estou começando a fazer na conta de produção para avaliar os resultados.

    Att,
    Júlio



  • Júlio, eu também não resolvi, apenas aprendi a conviver com a diferença. Comparando os resultados demo e backtest eu coloco uma margem de erro de 20% para cima ou para baixo.



  • Desculpe a demora pessoal.

    Qual a corretora?


    @Trader4127 said:

    Júlio, eu também não resolvi, apenas aprendi a conviver com a diferença. Comparando os resultados demo e backtest eu coloco uma margem de erro de 20% para cima ou para baixo.


  • @Rodrigo-Cohen no meu caso a corretora é a xp.



  • @Rodrigo-Cohen no meu caso é a Rico.

    Lembrando que verifiquei que mesmo executando os robos em produção e na conta teste o resultado é diferente, Não é necessário backtest para isto.

    O que ainda não tive tempo para avaliar é se executar o backtest na conta de produção o resultado é diferente.

    Obrigado,
    Júlio


Entre para responder
 

Parece que sua conexão com Fórum Portal do Trader caiu, por favor aguarde enquanto tentamos reconectar.